Memperbaiki EasyEngine yang Eror Setelah Update/Upgrade System

JagoTekno – Saya harus segera menulis artikel ini sebab EasyEngine saya eror setelah melakukan update.

TLDR : semua versi harus berada di versi yang sama, baik itu distro, docker dan php nya, hanya dengan mengedit file sourcelist.

Sebelumnya saya menggunakan setup :

  • Debian 11 bullseye
  • Docker container buster
  • php 7.3 buster
  • EasyEngine v4.5.5

Eror muncul setelah melakukan update versi EasyEngine dari 4.5.3 menjadi versi 4.5.5.

Perintah update easy engine ee cli update

Situs tidak bisa diakses, tapi masih bisa di ping.

Kemudian saya melakukan update system dengan perintah apt update && apt upgrade.

Tapi masih belum bisa diakses juga.

Analisa

apt update menunjukkan versi docker masih buster (debian 10) sedangkan system saya sudah bullseye (debian 11), makanya harus diupdate dulu source nya:

vim /etc/apt/sources.list.d/docker.list

vim /etc/apt/sources.list.d/php.list

Solusi

Ganti baris yang terdapat tulisan buster menjadi bullseye, setelah itu jalnkan apt update && apt upgrade

Jika muncul eror must run dpkg --configure -a, hapus dulu file lock pada 2 direktory ini :

rm /var/lib/apt/lists/lock
rm /var/cache/apt/archives/lock

Kemudian ulangi lagi dpkg --configure -a

Lalu apt upgrade.

Tunggu sampai selesai, dan semoga situs anda bisa up kembali.

Setelah melakukan cara ini

Tinggalkan komentar