Mengatasi Pesan Eror CodeIgniter4


JagoTekno.com - Saat belajar Codeigniter4, saya mencoba clone beberapa projek yang sudah ada di github. Namun beberapa projek tidak bisa langsung berjalan normal di system saya. Saya menemukan beberapa eror seperti :

  • require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead.
  • PHP Warning: Module ‘curl’ already loaded in Unknown on line 0

Pesan tersebut bisa diatasi dengan cara seperti ini :

Mengatasi pesan eror Codeigniter4 require-dev.mikey179/vfsStream is invalid, it should not contain uppercase characters. Please use mikey179/vfsstream instead.

Buka file composer.json yang ada di folder projek codeigniter lalu ubah baris mikey179/vfsStream mejadi huruf kecil semua.

Selesai.

Mengatasi PHP Warning: Module ‘curl’ already loaded in Unknown on line 0

Pesan ini muncul pada saat menjalankan codeigniter setelah mengetik php spark serve. Aplikasi berjalan normal tanpa melakukan cara ini tapi jika anda tidak ingin pesan itu muncul lakukan cara berikut :

Edit file curl.ini yang ada di /etc/php/7.4/apache2/conf.d/20-curl.ini

Kemudian berikan tanpa titik dua ; di depan extension=curl.so

Selesai.

Semoga membantu.

Install Pfetch dari pada Neofetch
Ditulis oleh Rafi pada Thursday, 7 April 2022
mrfdn author

Rafi

  • 15 year+ of Linux user.
  • 5 years+ blogger and web developer.

Jika artikel yang dibuatnya ternyata bermanfaat, support dengan cara

    Share:

Baca juga


comments powered by Disqus